MitID Unavailable

Incident Report for Uniify

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 14:05 CEST

Monitoring

The instability with MitID is unfortunately still ongoing. While more users are now able to successfully use MitID, some may still experience intermittent issues.
Posted Mar 31, 2026 - 13:19 CEST

Investigating

MitID is currently experiencing a outage. This affects all flows using MitID for identification or signing. Other flow types remain unaffected. We are monitoring the situation.
Posted Mar 31, 2026 - 09:16 CEST
This incident affected: MitID.